Help a Family in need
please just take a look
www.BearAndDragon.com
KBH v1.2.0.0 [WORKING] (kongregate badge hack)
by kolonelkadat
Never let a computer tell me shit.

firstly, try updating to the latest runtime (4.5)
secondly, make sure you arent blocking logicalspear.forceprojectx.com and forceprojectx.com. I load some runtime code from those addresses.




I use this AoB tool to make all the AoBs I post. Try the online version if you dont feel like downloading it.
"Obviously, windows are central to Windows. They are so important that they named the operating system after them. But what is a window?"

The Laziest Man on KongHack
Creamy Posted on: 03/07/2014 3:05pm
 Exception Info: System.AccessViolationException



try running it as administrator.




Created a new administrator account, ran KBH as that user - same result.
Any way to enable more verbose logging or something?
 




I have gone to find myself. If I return before I get back, please hold me here until I arrive.
Never let a computer tell me shit.

oh! i just thought of something. Is your computer running windows xp? because windows xp doesnt support this software.




I use this AoB tool to make all the AoBs I post. Try the online version if you dont feel like downloading it.
"Obviously, windows are central to Windows. They are so important that they named the operating system after them. But what is a window?"

Yes, it runs XP as i said in my first post. This and all my systems run XP.
KBH works fine at home, just not here on this netbook.
As XP isn't going away any time soon (despite what some people say), could you please try to target .NET 4 while building?

Anyways, since it currently works for me on 2 XP systems and doesn't work on a third one, it must be something else causing this.
Those addresses you mentioned, are they accessed on startup, or at a later point in time? Because KBH starts fine, it only crashes when i click the "send packet" button...
logicalspear.forceprojectx.com and forceprojectx.com open in IE, so they shouldn't be blocked anyways.

I'll be leaving the place in a bit, but if you have more suggestions i'll sure try them on my next visit.

[EDIT]
I just noticed something - this system is XP SP2 (2600.xpsp_sp2_rtm.040803-2158) while my systems at home are both XP SP3 (qfe builds). Could it be something missing in SP2 causing this?




I have gone to find myself. If I return before I get back, please hold me here until I arrive.
The Laziest Man on KongHack
Creamy Posted on: 03/08/2014 12:09am

[EDIT]
I just noticed something - this system is XP SP2 (2600.xpsp_sp2_rtm.040803-2158) while my systems at home are both XP SP3 (qfe builds). Could it be something missing in SP2 causing this?



yes. they call them service packs for a reason. they are a large bundle of windows software and security updates. you should update it.




Tested in Virtualbox - KBH crashes in clean XP SP2 witn only .NET4.0 installed.
But after i updated that to SP3 it still crashes...
Now trying some random updates to see if any would resolve this.

[EDIT]
Finally, got it working (in SP3) after installing a bunch of updates.
If anyone has the same issue - get autopatcher from http://www.autopatcher.net and install all .NET4 updates for your system.
These are the ones i installed:
 NDP40-KB2468871-v2-x86 NDP40-KB2487367-x86 NDP40-KB2533523-x86 NDP40-KB2600217-x86 NDP40-KB2600211-x86-x64 NDP40-KB2604121-x86 NDP40-KB2729449-x86 NDP40-KB2737019-x86 NDP40-KB2736428-x86 NDP40-KB2742595-x86 NDP40-KB2789642-x86 NDP40-KB2835393-x86 NDP40-KB2840628-v2-x86 NDP40-KB2861188-x86 NDP40-KB2858302-v2-x86



I have gone to find myself. If I return before I get back, please hold me here until I arrive.
The Laziest Man on KongHack
Creamy Posted on: 03/09/2014 3:59pm
got it working (in SP3) after installing a bunch of updates.
thenewcomer Posted on: 03/08/2014 1:16am

service pack... ...large bundle of windows updates. you should update it.



yup.




Never let a computer tell me shit.

Yay! im glad you  finally got it working! Thank you for the information too. Hopefully it will help others.




I use this AoB tool to make all the AoBs I post. Try the online version if you dont feel like downloading it.
"Obviously, windows are central to Windows. They are so important that they named the operating system after them. But what is a window?"

Guys,i can't install .net framework on my XP SP3...any ideas?When i open installer it does anything..

I get this error when i open a program who needs fwork..

KelHack Posted on: 03/10/2014 12:08pm

Guys,i can't install .net framework on my XP SP3...any ideas?When i open installer it does anything..

I get this error when i open a program who needs fwork..



Try the Autopatcher from my previous post?
btw. the usual value of that registry key is C:\WINDOWS\Microsoft.NET\Framework\


OK, small update on my issue with that netbook - KBH needs a functional Internet Exploder with Flash to work properly.
I first tried just the .NET4 updates, but KBH was still crashing when trying to send a packet.
Then i installed SP3, but KBH crashed again.
After monkeying around for a bit, i found out IE was removed on this netbook - the core was there though, so you can type an URL in Windows exploder and have it openned.
So, i installed IE8, reinstalled Flash for it, and from there on KBH started working :P

Obviously, i can't try this on the netbook without SP3 anymore, and installing the updates in Virtualbox takes ages, so if anyone still has a SP2 install - try first doing the above updates without SP3 and report the results here.




I have gone to find myself. If I return before I get back, please hold me here until I arrive.
goku90504 Posted on: 12/02/2013 10:31pm

i'm getting a
Error HRESULT E_FAIL has been returned from a call to a COM component
error when i try to submit the packet

 



Just downloaded this, and I'm getting the same issue. I can log in just fine, but submitting a packet crashes the app. Tried it with 3 different games: Exit Path, Flood Runner 3, and Pretentious Game 2. Its not clear if the post following the post I'm quoting is supposed to address this issue or not (ie, make sure its not blocked and that all files are present) so just in case, I know it is not being blocked, and here are the files that came with the download:

Forgot to add that my OS is Win 7 64 bit
04/09/2014  10:38 AM    

         .
04/09/2014  10:38 AM    

         ..
06/29/2013  03:21 AM            17,920 AxInterop.ShockwaveFlashObjects.dll
06/29/2013  03:21 AM            22,528 Interop.ShockwaveFlashObjects.dll
08/06/2011  09:01 PM           102,400 Ionic.Zlib.dll
08/28/2013  11:19 PM           460,800 KongregateBadgeHack.exe
               4 File(s)        603,648 bytes
               2 Dir(s)  26,855,342,080 bytes free

Never let a computer tell me shit.

Error HRESULT E_FAIL has been returned from a call to a COM component

is encountered when the advertisement swf does not load. that swf contains special code that allows the .exe to interact with the kongregate api. If that swf does not load, then the .exe cannot send data to kongregate. 




I use this AoB tool to make all the AoBs I post. Try the online version if you dont feel like downloading it.
"Obviously, windows are central to Windows. They are so important that they named the operating system after them. But what is a window?"

My bad. I had incorrectly assumed the advertisement did not load because the project wasn't really being actively updated (due to few users) or because maybe it was a mochibot thing. I did not think I was blocking anything, but I was using this at work at for some reason my company blocks access to forceprojectx. :/ Using it at home (outside teh company firewall) fixed it right up. 

 

Thanks for this tool.  I can confirm it works as promised.