Boost Your Website Traffic
Try the new KongHack Ad Manager
Increase your traffic today!
[Help] Bad quality of video recorded using OBS/Fraps/Shadowplay

Hello,
i've tried to record some videos from games on new PC but unfortunately my recorded videos looks like... *bad*.
It's choppy or looks like it wouldnt be recorded in 60fps but just like under 30. Video here has ~25mins. And first 10mins are extremely choppy but the rest are ok.
Using OBS:
I've tried "Simple output", High quality, Indisting. quality. In "Advanced" i've tried CBR and CQP (few times each option).
And one video is great, another time it's horrible. (recorded on same option) [for example CBR 16000: 1 video 15mins is ok, 2 video is horrible, 3 video is 50:50].
Using Shadowplay is almost the same as like using OBS Studio but video is ruined all the time.
Using Fraps it's something more complicated. While recording my FPS in game dropping from 60 to 44 for every 5-8 seconds. Recorded video looks horrible.
I've no idea what's going on. I've tried to record videos on 2 different HDD and even on SSD. Im out of ideas what mind cause the problem.

My PC spec:
CPU: i7 6700k 4.0  @4.2
GPU: GTX 970 Asus Strix
Mobo: MSI z170a Gaming M5
RAM: Ripjaw 5 16GB  3000MHz
PSU: Evga 750w SuperNova G2
SSD: Samsung EVO 850  256GB
HDD: 1. WD Black,   2. Seagate Barracuda

Before upgrade i was using CPU i5 2400, old Asus Mobo, PSU Corsair CX 600(or 650), GTX 970 and old RAM 16GB.  I had no problems with video recording. Everything happened when i upgraded to new one.

Anyone has any idea what mind cause such problems? I'd really appreciate for any kind of help.

Competing For Laziest Man On KH

I've had some absolute shit videos come out with some mid-high specs and my main problem was using too low of a bitrate. Although this doesn't sound like your issue, you could try upping the bitrate in OBS. Another attempt might be to upgrade video drivers cause the captures may be relying on back-up techniques or some shit




I have no clue about streaming and recording but did you reinstall your windows after the upgrade or did you just uninstalled old drivers and installed new ones? Often this is causing problems in many different ways. It`s often enough to have just a tiny pile of a rest of the old drivers to cause problems. So if you dont uninstall and clean the drivers properly, this may be your problem. But I have no clue if it would work to reinstall the windows. I mean, from what I understand, you technically changed your HDD to a whole new system. If you dont reinstall windows this HAS to be a problem^^

If you cant find any other solution, then try that. First try to update your bios. Maybe that helps.

Ubi Maior Minor Cessat

Links to short video samples or even screenshots could be helpful to pinpoint the potential problems. Also the actual configuration/settings might be a good idea too.

If you can't be arsed to read about different options/algorithms you might as well try some presets for similar goals
2c

TIM the Enchanter
Level: 1
ADR Info

My output settings in OBS
Video Bitrate: 2500
Encoder: Software (x264)
Audio Bitrate: 160

Quality: Same as stream
Format: FLV

Video - 
Base: 1920x1080
Scaled: 1280x720
Filter: Bicubic
FPS: 30

I record to a secondary SSD.  That way I'm not chewing up internal bandwidth.  
 





Everything's coming up KongHack!

"When you know nothing matters, the universe is yours" ~Rick Sanchez

I haven't played around with settings too much. I don't know what a proper bitrate is for the things I record, but here's what I use to record osu!:
Format: mp4 (might switch to something else)
Encoder: x264
Rate: VBR
Bitrate: 20000 (definitely too much for osu, that doesn't have much details other than on the skin)
CRF: 12
CPU preset: ultrafast (lowest CPU usage)
Video:
- 1680x1050
- 60 FPS
- No scale (same res)
Audio:
- 192kbps (computer sound)

With the current setup, I get ~330 FPS (note that the game uses very few resources by itself, I'm getting 450 FPS normally and I'm running on a GT 540M and an i7 2630QM) with a few stutters here and there that don't appear in the recording.

I've used fraps before. Lag spikes everywhere, huge files.
My GPU doesn't support Shadowplay so I can't tell you anything about that one.




"This dancing Spiderman GIF will dance to any song" - Tumblr
"You cannot dance to the beat when the beat is non-existent" - Kobaryo, DJKurara, LeaF, Team Grimoire, Camellia, IOSYS, t+pazolite, The Quick Brown Fox, goreshit, Igorrr, Hypernite Industries, Nivradoo, and every other speedcore composer you can think of.

Sorry for late in answering guys.
After upgrade to new PC i reinstalled whole system. And for now i've tried to reinstall it one more time but still no changed in video recording.
But mainly the problem is not only with OBS. Same video quality i can reach using FRAPS and Shadowplay. I dont think it's a problem with Bitrates or programs... probably something wrong is or with my Windows (somehow?) or in other things. I quess i'll have to send my PC back on warranty.
 

Competing For Laziest Man On KH

It would help for us to have video samples from at least 2 of the programs for us to see what is actually happening




Okay. Here is the sample of video: It was recorded using OBS Studio.
https://youtu.be/rejn0esRcp8

I dont think there is a need to upload second video when i was using Shadowplay because the quality/stuttering/dropping fps on video are exactly the same as the one in this video. (if there is a need i can upload)

MichalESK Posted on: 05/15/2017 3:26pm

Okay. Here is the sample of video: It was recorded using OBS Studio.
https://youtu.be/rejn0esRcp8

I dont think there is a need to upload second video when i was using Shadowplay because the quality/stuttering/dropping fps on video are exactly the same as the one in this video. (if there is a need i can upload)



"Video is unavailable"
 




"This dancing Spiderman GIF will dance to any song" - Tumblr
"You cannot dance to the beat when the beat is non-existent" - Kobaryo, DJKurara, LeaF, Team Grimoire, Camellia, IOSYS, t+pazolite, The Quick Brown Fox, goreshit, Igorrr, Hypernite Industries, Nivradoo, and every other speedcore composer you can think of.

Competing For Laziest Man On KH
MichalESK Posted on: 05/16/2017 8:54pm

Reuploaded.

https://youtu.be/40op4wy-bWY



Video looks good to me. No stuttering or quality isues from the portions I viewed.

If some stuttering happens, I'd wager it's your CPU or GPU (whatever's doing the recording) being maxed at the moment.




Try Bandicam and download a keymaker and it's completely free and good too and I use it.